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Introduction

• What do we want from computer programs?
– Reliability
– Extendability & Reusability

• Reliability
Ability of systems to meet their contractual
obligations

• Correctness
• Robustness
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Introduction
• Correctness

Ability of software to perform according to its
required specification

• Robustness
Software is fault tolerant
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Introduction

Is it possible to make software
systems that satisfy their
requirements and do not fail?
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Critical Role of Software Systems

• Monitoring Systems
• Aviation
• Nuclear War-Heads
• Medicine
• Weather Reporting
• Water Dams
• Nuclear Reactors
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Professional Responsibility
• What are the consequences of system

failure?
• Who is ultimately responsible?

– Programmer
– Analyst
– Client



Tony Mullins Griffith College Dublin 7

System Misbehaviour
• Defects in the stated requirements of the

system
• Defects in the specification that fail to meet

the stated requirements
• Defects in the program that fail to meet the

given specification
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System Misbehaviour
Other possible reasons for failure:
• hardware errors
• system software faulty
• incomplete specification
• failure to integrate with existing software
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System Misbehaviour

It has been shown that the earlier an
error is discovered in the development
process and the system altered, the
cheaper the alteration will be.
Too often errors are only found when
testing or deployed!
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System Requirements

• Provided by Client
– Domain experts
– Brain storming sessions
– Research

• Documentation
– Natural language
– Diagrams
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Specification
• Contract between client and system

developer
• Developed system must meet requirements

stated in specification
• Contract satisfied once system meets

specification
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Specification Notations
• Informal

– Natural language + diagrams
• Semi-Formal

– Graphical notations - JSD, UML
• Formal
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Abstract Data Types
• An abstract data type is a set of objects

capable only of particular kinds of
behaviour, which correspond to a finite set
of allowable operations on objects of the
type. (Liskov & Berzins)
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Abstract Data Types
• Its behaviour is completely characterized by

the behaviour of the operations.
• Access to the representation of the object

restricted to the operations of the type
• Representation may be changed as long as

behaviour of operations preserved
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Specification Program

• Defines contract with
client

• Defines what system
must do

• Abstracts from
implementation details

• Provides basis for test
cases

• Documentation for
system

• Description of how to
implement the what of
the contract

• Concerned with:
–  performance issues
– use of system

resources
– robustness and fault

tolerance
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Specification Program
Correct if there are no
errors, ommissions,
contradictions or
ambiguities in the
contract.

• Correct if it performs
according to
requirements defined
in contract

• Robust if it is capable
of handling situations
not covered in the
specification
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Degrees of Formality
Specification Program

How to derive program from specification:
– Formal specification only
– Formal specification & rigorous development
– Formal spec & formal development
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Degrees of Formality

Formal Spec only:
– Gives precise unambiguous statement of what

system is to do
– Use as guide for design and implementation

with informal design techniques
– Valid spec against requirements to discover

discrepancies and resolve them
– Used to formulate test cases after coding
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Degrees of Formality

Formal spec with rigorous dev:
– Formality applied to both specification and

development.
– This means writing both abstract and concrete

specifications and recording the development
relations between them.

– Mappings from abstract to concrete are not
justified
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Degrees of Formality

Formal Spec & Formal Dev:
– Formality applied to both specification and

development.
– This means writing both abstract and concrete

specifications and recording the development
relations between them.

– Mappings from abstract to concrete are justified
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Degrees of Formality

Formal Spec only:
• Provides solution to error discovery
• Fails to solve the error avoidance problem

because there is no justification of the
relation between specification and code.
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Degrees of Formality

Formal Spec & Rigorous Dev:
•  solve both:

– error discovery
– error avaoidance

• Also provide a record of how development
was done that is invaluable for maintenance,
extendibility and reuse

• Does not solve testing problem



Tony Mullins Griffith College Dublin 23

Degrees of Formality

Formal Spec & Formal Dev:
• Solves error detection and avoidance.
• Provides necessary documentation for

maintenance, extendibility and reuse
• Solves testing problem
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Styles of Specification

• Algebraic
– Algebras and abstract data types
– Homomorphic mappings between algebras

• Model Oriented
– Based on notional state
– Sets, relations and functions



Tony Mullins Griffith College Dublin 25

Algebraic

• A type in an algebra corresponds to a set of
elements

• Functions describe the operations associated
with the type

• Axioms define the semantics of the
operations

• Preconditions define restrictions on the type
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Algebraic

Implementations are treated as other
algebras and correctness is achieved
through showing the existence of
homorphic mappings from one algebra to
the other.
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Stack

• TYPE
•  STACK [G]

• FUNCTIONS
• put: STACK [G] X G → STACK [G]
• remove: STACK [G] →  STACK [G]
• item: STACK [G] → G
• empty: STACK [G] → BOOLEAN
• new: → STACK [G]
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Stack

• AXIOMS
– For any x: G, s: STACK [G]
– A1  item (put (s, x)) = x
– A2  remove (put (s, x)) = s
– A3  empty (new)
– A4  not empty (put (s, x))



Tony Mullins Griffith College Dublin 29

Stack
PRECONDITIONS

–  remove (s: STACK [G]) require not
empty (s)

–  item (s: STACK [G]) require not empty
(s)
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Model Oriented Specifications

• Permit rigorous analysis of system
functionality

• Provide proof of consistency and
correctness

• Provide a model of what system must do
• Abstract from implementation issues
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Model Oriented Specifications
• Based on sets, relations, functions and

discrete mathematics
• Provide abstract data types through

– abstract variables
– state invariants
– operations on the state
– operations expressed in terms of a rule that

relates pre-condition with post-condition
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Model Oriented Specifications
– Initialisation operations that must satisfy state

invariant
• Provide a syntactic and semantic model of

composition, i.e. a method to compose new
specifications from existing ones.

• A proof theory
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Model Oriented Specifications
• Potential for formal derivation of program

code from initial specification
• Rules of refinement
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Model Oriented Notations

• Z J. Abrial & Oxford Group
• B-Method J.Abrial & I. Sorenson
• Perfect D. Crocker & Escher

Technologies
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Z

• Model oriented notation
• Used to specify IBM CICS development

tools
• Adopted by IBM and used for research at

Hursley Park
• Tool support
• Formal Specification only
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Z Specification
• Specify given types
• Specify state space
• Specify initialisation
• Specify operations on the state
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B-Method
• Model oriented notation
• Used to specify and implement Paris

underground metro
• Tool support
• Theorem prover that can be used at all

stages of development
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B-Method
• Refinement model
• Code generation

– C++
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Perfect
• Model oriented specification language

based on Object-Oriented Paradigm
• Used to specify and implement itself!
• Tool support
• Theorem prover that can be used at all

stages of development process
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Perfect
• Refinement model
• Code generation

– C++
– Java
– Ada
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Features of PD

Teaching Prof Enterprise Safety-critical
Automatic code generation yes yes yes yes
Automated verification yes yes yes yes
Unlimited project size yes yes yes
Distributed verification yes yes
System-wide property checking yes yes
Human-readable proof output yes yes yes yes
Machine-readable proof output yes
C++ code generation yes yes yes yes
Java code generation yes yes yes yes
Ada 95 code generation yes
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Formality
Both B and Perfect provide development
environments that allow:
– formal specification
– proof of correctness
– proof of refinement
– code generation
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Platforms
• B

– Unix and Linux only
• (B-Core U.K. Ltd, Atelier B, France)

• Perfect
– Window
– Unix and Linux

• Escher Technologies U.K.
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Platforms

Perfect developer provides:
• an object oriented specification and design

tool;
• verified design by contract.
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Perfect Developer

• Student Edition
– € 120

• Professional Edition
– € 9000

• Safety Critical Edition
– € 21500
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Course Content
• Lecture 1

– Introduction
– Crimson Editor
– Perfect Developer

• Lecture 2
– Types

• nat, char, int, bool, real, string
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Course Content
– Functions
– Properties and assert
– Recursion and recursive functions

• Lecture 3
– Classes in Perfect

• Object-oriented model
• Design by contract in Eiffel
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Course Content

• Differences between Perfect and Eiffel
• Structure of a class

• Lecture 4
– Set theory
– Specifying with sets

• Lecture 5
– Bag theory
– Specifying with bags
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Course Content

• Lecture 6
– Theory of sequences
– Specifying with sequences

• Lecture 7
– Functions
– Specifying with functions

• Lecture 8
– Refinement
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Course Content

• Lecture 9
– System specification

• Lecture 10
– System specification

• Lecture 11
– Genericity

• Lecture 12
– Inheritance
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Assessment
• Tutorials & Worksheets

– 5%
• Assignment

– 15%
• Exam

– 80%
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Editor
Crimson Editor

Available at:
www.crimsoneditor.com

To configure editor for Perfect put
Extension.pd in link directory
Perfect.spc in spec directory
Perfect.key in spec directory
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Editor
• Perfect.key contains

– collection of perfect key words and their
associated colours

• Perfect.spc
– specification file for Perfect

delimiters,comments, quoptes,etc
(Files written by Gareth Carter, Maynooth)



Tony Mullins Griffith College Dublin 54

Editor

Run Crimson and Click on "Document ->
Syntax Type -> Customize"

Scroll down to an Empty type and type
In Description "Perfect"
In Lang Spec "PERFECT.SPC"
In Keywords "PERFECT.KEY"
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Perfect Developer
Run Perfect and click on

Options -> Editor
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Perfect Developer

Run Perfect and click on
Options -> Editor
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Perfect Developer
• To create a new project
• Create a directory with project name
• Click on File->New Project
• Select directory
• Click on Project ->Creat file
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Perfect Developer
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Perfect Developer
• A file called Exampl1.pd is created and displayed

in the window below
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• /*******************************************************
• //* File:    C:\My Documents\PerfectDeveloper\Examples\Example1\Example1.pd
• //* Author:  Tony Mullins
• //* Created: 16:37:14 on Saturday January 17th 2004 UTC
• //*******************************************************

• class Example1 ^=
• abstract
• // Add variable, invariant and private method declarations here...
• interface
• // Add public access function, selector and method declarations here...
• // ...
• build{}
• post ?;
• end;

• // End
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